Modern amps, boo. Also guitars.

Props to the guy that brought me this Marshall valve state, stopped using it when it started making funny noises, not continue using it till it explodes. this makes fixing a case of finding the problem and fixing, rather than replacing lots of exploded things, which is boring and ballache on PCB.

Starting at the start, the power lead tucked in the back, pretty wrong to see on the outside with the inner insulation showing, inside, not much better:

Neutral pretty much disconnected, most of the strands broken. Plugs should be a big deal, but figured should probably mention since stuff like this exists. Cut off the wires, and redid it so the clamp holds the main insulation, also tinned the ends of the wires for good measure.

First thing I do when I get an amp in to fix is open it up and clean everything, hoover out, spray the pots, cotton bud and meths into the sockets, clean valve bases. So if that is the problem, it won’t be any more an I can’t blow it up as soon as I test it due to dirt. The problem with this one, after doing that was some cutting out and crackling when you putt on the input lead, or wiggle the knobs in the first channel. Classic board mount pot problem of one pulling out of the pcb. All the knobs off, all the nuts on the jacks and the pots off (Valvestates luckily only have nuts on some of the pots). Then the little press connectors that push through the PCB have to be eased off. Someone has been in here before and snapped most of them off, so that wasn’t too hard. The last bit involves sliding out the whole PCB an you very nearly have to take out the whole transformer to do it, but there is just enough spring in the chassis:

Edited out some extreme messy workbench there. Once that’s like that, can get at everything. And here is is:

Third pin on that pot doesn’t have a nice mound of solder round it. Soldered that up and did all the others for good measure. Something on some of them repelled the solder, interesting, possibly why it went to start with, but the fact that using the volume and the input jack flexes that part of the board is more likely the reason. This is why pots with leads are better. All went back together easy enough, and good to go.

Have this to look at next:

Fun part of this is he was using it for 6 months like that, as the string clamp for the locking trem kept them in place, they’ve grown a crust now so sorting time. Far from ideal as there is now 6 months worth of crud in the joint so I can’t just inject glue, clamp, and be good to go.

Advertisements